My campaign didn't collect any attributes

You've taken great care in creating your campaign and deployment, but it's not working as planned?

No worries! We've put together a list of solutions to help you quickly resolve the situation.

The elements below will allow you to easily identify the blocking points that could explain why your attributes are not attached to your answers.

  1. Is my segment properly attached to my campaign?
  2. Is my segment properly set up?
  3. Are my attributes present in my source?
  4. Does the value returned match the attribute format/type defined in MyFeelBack?

1. Is my segment properly attached to my campaign?

The segment allows you to make the link between your attributes and your campaign, check that your segment is attached to your campaign.

Capture d’écran 2021-04-08 à 18.18.19

For more information on the segments read this article

 

2. Is my segment properly set up?

  • Is your segment inactive? If so, activate it.
  • Does your segment have a deployment date? If so, does the period defined correspond to the current date ? In general, we advise you not to set a deployment date, so it will always be active.
  • Does your segment contain all the attributes you want to attach to your response? Check the list of attributes attached to the segment and add the missing attributes if necessary.

    Capture d’écran 2021-04-08 à 18.19.35

     

    3. Are my attributes present in my source?

    • In the case of sending from an external solution : 
      • Check that your URL contains the attribute values by opening the link contained in the email, SMS or other.
        • Here is an example where the attribute is valued:
          https://room.myfeelback/website/.../fullpgae?d:id=123456&country=UK&oid=...
        • Here is the same example where the country is not present in the URL:
          https://room.myfeelback/website/.../fullpgae?d:id=123456&country=&oid=...
      • No value comes up, check your integration in your tool: Did you put the right variable code? Does this data exist in your tool?
    Here is an article on How to attach attributes to a URL deployment?

     

    • In the case of sending an email or SMS from MyFeelBack
      • Did your contact collect this information? Check this in the Contact section of the contact form

      • Is the attribute linked to the contact field in your attribute configuration?

    Capture d’écran 2021-04-08 à 18.21.34

    Note: by clicking on the  button, we do not link to the contacts on your list. This allows you to solicit any email address but does not validate the collection of attributes.

     

    • In the case of a website deployment
      • Check that the attributes used for your deployment are valued in the tag. Go to your browser's console (Ctrl+Shift+J). Once you have access to the Console, type _Mfb_ud next to the blue arrow. Press enter

      • Do the missing attributes appear and are they valued correctly? If not, your tag is not up to date or this data is not available. Here is an article on the MyFeelBack tag.

    4. Does the value returned match the attribute format/type defined in MyFeelBack?

    Have you checked that the data passing through the URL or tag matches the format defined? As a reminder :

      • Numeric: The attribute will only accept numbers, other data will be ignored.
      • Date: The date format is defined by you.
      • Value list: You define the values to be taken into account, the others will be ignored.
      • Email: The attribute will only accept emails, other data will be ignored.
      • Phone number: The attribute will only accept phone numbers, all other data will be ignored.

    Please also check for case and space.


    _______________________________________________________

    Want to try? Click here